Author Topic: MPX Multicont ESC failsafe problem  (Read 3801 times)


  • Newbie
  • *
  • Posts: 131
    • View Profile
MPX Multicont ESC failsafe problem
« on: June 01, 2020, 22:06:54 PM »

I've obviously not refined my google search term enough as Prof. Google is not being his usual helpful self.

I'm taking advantage of the no fly time and migrating my models to a new (to me) transmitter.

MPX Acromaster, with Acromaster Power Set.

Everything works fine, until I power the transmitter back up after testing the failsafe.
Before turning off the transmitter the motor responds to the throttle as expected.

Then I test the failsafe, by turning the transmitter off.
Failsafe kicks in, motor stops. Happy days.

Then I turn the transmitter back on again...

The ESC just ignores the throttle, I can wiggle the throttle anyway I like, but the only way to stop the motor turning is to turn off the transmitter, again, so that the failsafe kicks in again.

I'm definitely puzzled by this as the Acromaster is the last model I've moved to the new transmitter, but its the only one that has given me this kind of hassle.

All the rest of my models have various far eastern (EMAX/Turnigy/Hobbyking/Ripmax) ESCs, and they all behave normally, as one would expec,t after the failsafe condition is removed (transmitter switched on again).

Maybe the answer really is in the ESC manual, but I've not spotted it so far - though maybe todays sunshine went to my head and I missed it. All off my other ESC's just work, and with the exception of the Acromaster the rest of the fleet is ready to commit aviation. Since none of my cheapo ESCs have this problem I can't believe that its an issue with the transmitter.
I didn't even have to go looking for the ESC manuals for any of my other models.

I guess one solution would be just to swap out the ESC, but I'll need to use the MPX ESC in something, sooner or later.

I've tried moving the throttle to idle and back up again, but no joy - in fact the transmitter won't transmit unless I have the throttle at idle anyway after power up, so no choice in the matter there, but  repeating the arming sequence should not matter as the ESC was powered all through the failsafe test.

Any one come across this before? Any suggestions?



  • ISR Club Member
  • Newbie
  • *
  • Posts: 1132
    • View Profile
Re: MPX Multicont ESC failsafe problem
« Reply #1 on: June 02, 2020, 08:29:06 AM »
The answer to the problem is the trim on the radio has not gone low enough. There will be lots of replies I have done this and done that but the simple fact is that the esc is not arming itself due to the incorrect throttle position signal.



power up esc and tx.   move trim to lowest position ,if no
 then go to subtrims and lower the throttle value.

If no check to see if throttle is reversesd and repeat above for new throttle setting.

If the ESC is not defective this usually works.

Spots or no Spots?
Tuff Choice.


  • Newbie
  • *
  • Posts: 131
    • View Profile
Re: MPX Multicont ESC failsafe problem
« Reply #2 on: June 04, 2020, 19:19:32 PM »
Thanks Ralph,

That worked.

Throttle travel and limit set to max. Fixed it.

The rest of my ESCs work fine with 100% travel, but this one needed the full 155%

Don't quite understand why though as the ESC was arming and operating normally until I initiated the failsafe.

We live and learn